VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetInfoAt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the property set name, if it is attached and where from (mapping or record).
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
bAllPsets
bAllPsets
bool  
bool  
no info.
Boolean that defines whether customPsets are to be checked.
</line>
</line>
<line>
<line>
index
index
short  
short  
no info.
Index that defines the pset position.
</line>
</line>
<line>
<line>
outIfcPsetName
outIfcPsetName
TXString
TXString
no info.
Returns the property set name
</line>
</line>
<line>
<line>
outType
outType
short
short
no info.
Returns the index that defines the state of the Pset. Possible values are: <b>-2</b> (pset forbidden from mapping, NOT attached in record), <b>-1</b> (pset forbidden from mapping, but attached in record), <b>0</b> (pset NOT attached), <b>1</b> (pset attached from record), <b>2</b> (pset attached from mapping)
</line>
</line>
</lineList>
</lineList>
Line 59: Line 59:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 86: Line 82:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2018.
</version>
</version>



Revision as of 11:13, 3 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the property set name, if it is attached and where from (mapping or record).

VCOMError IFC_GetPsetInfoAt(
MCObjectHandle hObject,
bool bAllPsets,
short index,
TXString& outIfcPsetName,
short& outType);

Parameters

hObject MCObjectHandle Handle to object.
bAllPsets bool Boolean that defines whether customPsets are to be checked.
index short Index that defines the pset position.
outIfcPsetName TXString Returns the property set name
outType short Returns the index that defines the state of the Pset. Possible values are: -2 (pset forbidden from mapping, NOT attached in record), -1 (pset forbidden from mapping, but attached in record), 0 (pset NOT attached), 1 (pset attached from record), 2 (pset attached from mapping)

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.