VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPropertiesListOfPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
 
Returns the full list of properties of the Proserty Set (PSet). The function works with active IFC document.
...put some description here...
</desc>
</desc>


Line 25: Line 24:
strIfcPsetName
strIfcPsetName
TXString
TXString
no info.
Property Set name.
</line>
</line>
<line>
<line>
outArrProperties
outArrProperties
TXStringArray
TXStringArray
no info.
Output parameter, the list of properties.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 43:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 71: Line 66:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017
</version>
</version>



Latest revision as of 07:10, 23 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport Returns the full list of properties of the Proserty Set (PSet). The function works with active IFC document.

VCOMError IFC_GetPropertiesListOfPset(
const TXString& strIfcPsetName,
TXStringArray& outArrProperties);

Parameters

strIfcPsetName TXString Property Set name.
outArrProperties TXStringArray Output parameter, the list of properties.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017