VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPropertiesListOfPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 43: Line 43:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>

Latest revision as of 07:10, 23 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport Returns the full list of properties of the Proserty Set (PSet). The function works with active IFC document.

VCOMError IFC_GetPropertiesListOfPset(
const TXString& strIfcPsetName,
TXStringArray& outArrProperties);

Parameters

strIfcPsetName TXString Property Set name.
outArrProperties TXStringArray Output parameter, the list of properties.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017