VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPropertiesListOfPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 8: Line 8:


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
 
Returns the full list of properties of the Proserty Set (PSet). The function works with active IFC document.
...put some description here...
</desc>
</desc>


Line 25: Line 24:
strIfcPsetName
strIfcPsetName
TXString
TXString
no info.
Property Set name.
</line>
</line>
<line>
<line>
outArrProperties
outArrProperties
TXStringArray
TXStringArray
no info.
Output parameter, the list of properties.
</line>
</line>
</lineList>
</lineList>
Line 71: Line 70:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017
</version>
</version>



Revision as of 07:09, 23 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport Returns the full list of properties of the Proserty Set (PSet). The function works with active IFC document.

VCOMError IFC_GetPropertiesListOfPset(
const TXString& strIfcPsetName,
TXStringArray& outArrProperties);

Parameters

strIfcPsetName TXString Property Set name.
outArrProperties TXStringArray Output parameter, the list of properties.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017