VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPropertiesList: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(4 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the list of members for an IFC entity
</desc>
</desc>


Line 25: Line 25:
scheme
scheme
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|EIFCSupportSchema]]
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|EIFCSupportSchema]]
no info.
IFC Scheme. Possible values are <b>kIFCSupportScheme_2x2</b> (IFC 2x2); <b>kIFCSupportScheme_2x3</b> (IFC 2x3) and <b>kIFCSupportScheme_2x4</b> (IFC 4).
</line>
</line>
<line>
<line>
strIfcObjName
strIfcObjName
TXString
TXString
no info.
IFC entity name.
</line>
</line>
<line>
<line>
outArrProperties
outArrProperties
TXStringArray
TXStringArray
no info.
Returns list of entity members.
</line>
</line>
<line>
<line>
outArrDefaultValues
outArrDefaultValues
TXStringArray
TXStringArray
no info.
Returns list of default values for entity members. Currently returning empty list.  
</line>
</line>
</lineList>
</lineList>
Line 56: Line 56:
</line>
</line>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoInterface
Bad VCOM instance used to call the function.
During [[SDK:GS_VWQueryInterface]] or [[VCOM:VCOMPtr]] notifying that there is no instance with requested [[VCOM:VWIID]].
</line>
<line>
kVCOMError_Failed
Routine failed.
</line>
</line>
</lineList>
</lineList>
Line 81: Line 77:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2016.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_GetPropertiesList]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_GetPropertiesList]]

Latest revision as of 15:27, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the list of members for an IFC entity

VCOMError IFC_GetPropertiesList(
EIFCSupportSchema scheme,
const TXString& strIfcObjName,
TXStringArray& outArrProperties,
TXStringArray& outArrDefaultValues);

Parameters

scheme EIFCSupportSchema IFC Scheme. Possible values are kIFCSupportScheme_2x2 (IFC 2x2); kIFCSupportScheme_2x3 (IFC 2x3) and kIFCSupportScheme_2x4 (IFC 4).
strIfcObjName TXString IFC entity name.
outArrProperties TXStringArray Returns list of entity members.
outArrDefaultValues TXStringArray Returns list of default values for entity members. Currently returning empty list.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NoInterface During SDK:GS_VWQueryInterface or VCOM:VCOMPtr notifying that there is no instance with requested VCOM:VWIID.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2016.