VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPropChoices: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Gets enumeration values of a Field.
</desc>
</desc>


Line 25: Line 25:
strIfcName
strIfcName
TXString
TXString
no info.
IfcEntity or Property Set name.
</line>
</line>
<line>
<line>
strIfcPropName
strIfcPropName
TXString
TXString
no info.
Field name.
</line>
</line>
<line>
<line>
outArrChoices
outArrChoices
TXStringArray
TXStringArray
no info.
Out parameter. Contains all enumeration values for the Field.
</line>
</line>
</lineList>
</lineList>
Line 49: Line 49:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 76: Line 72:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019
</version>
</version>



Latest revision as of 11:23, 29 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Gets enumeration values of a Field.

VCOMError IFC_GetPropChoices(
const TXString& strIfcName,
const TXString& strIfcPropName,
TXStringArray& outArrChoices);

Parameters

strIfcName TXString IfcEntity or Property Set name.
strIfcPropName TXString Field name.
outArrChoices TXStringArray Out parameter. Contains all enumeration values for the Field.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019