VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetParamsCount: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Returns the count of the parameters (properties).
</desc>
</desc>


Line 25: Line 25:
hFormat
hFormat
MCObjectHandle
MCObjectHandle
no info.
Handle to the format
</line>
</line>
<line>
<line>
outParamsCnt
outParamsCnt
size_t
size_t
no info.
Parameters count.
</line>
</line>
<line>
<line>
recType
recType
ERecordIFCType
ERecordIFCType
no info.
The type of the format record. Possible values are None, IFC, PSet, IFCTag.
</line>
</line>
</lineList>
</lineList>
Line 49: Line 49:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>

Revision as of 14:52, 8 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the count of the parameters (properties).

VCOMError IFC_GetParamsCount(
MCObjectHandle hFormat,
size_t& outParamsCnt,
ERecordIFCType recType = ERecordIFCType::None);

Parameters

hFormat MCObjectHandle Handle to the format
outParamsCnt size_t Parameters count.
recType ERecordIFCType The type of the format record. Possible values are None, IFC, PSet, IFCTag.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.