VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetParamsCount: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
 
(6 intermediate revisions by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the count of the parameters (properties).
</desc>
</desc>


Line 25: Line 25:
hFormat
hFormat
MCObjectHandle
MCObjectHandle
no info.
Handle to the format
</line>
</line>
<line>
<line>
outParamsCnt
outParamsCnt
size_t
size_t
no info.
Parameters count.
</line>
</line>
<line>
<line>
recType
recType
ERecordIFCType
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|ERecordIFCType]]
no info.
The type of the format record. Possible values are None, IFC, PSet, IFCTag.
</line>
</line>
</lineList>
</lineList>
Line 49: Line 49:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 76: Line 72:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_GetParamsCount]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_GetParamsCount]]

Latest revision as of 15:26, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the count of the parameters (properties).

VCOMError IFC_GetParamsCount(
MCObjectHandle hFormat,
size_t& outParamsCnt,
ERecordIFCType recType = ERecordIFCType::None);

Parameters

hFormat MCObjectHandle Handle to the format
outParamsCnt size_t Parameters count.
recType ERecordIFCType The type of the format record. Possible values are None, IFC, PSet, IFCTag.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.