VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetParamValue: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 39: Line 39:
<line>
<line>
recType  
recType  
ERecordIFCType
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|ERecordIFCType]]
Record type, possible values are: None, IFC, PSet, IFCTag.
Record type, possible values are: None, IFC, PSet, IFCTag.
</line>
</line>

Revision as of 13:27, 3 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the parameter value.

VCOMError IFC_GetParamValue(
MCObjectHandle hFormat,
size_t paramIndex,
TXString& outParamValue,
ERecordIFCType recType = ERecordIFCType::None);

Parameters

hFormat MCObjectHandle Handle to the format record.
paramIndex size_t Parameter index.
outParamValue TXString Out parameter for the result.
recType ERecordIFCType Record type, possible values are: None, IFC, PSet, IFCTag.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.