VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetParamIndex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

IFC records have different structure from other Vectorworks records. Now think for IFC record as a list of pairs (property, value). The first property has index 0. Use that function to return the index. The functions has two overloads:

VCOMError IFC_GetParamIndex(
MCObjectHandle hFormat,
const TXString& paramName,
size_t& outParamIndex,
ERecordIFCType recType = ERecordIFCType::None);
VCOMError IFC_GetParamIndex(
MCObjectHandle hFormat,
size_t paramIndexIFC,
size_t& outParamIndex,
ERecordIFCType recType = ERecordIFCType::None);

Parameters

hFormat MCObjectHandle Handle to the record format.
paramName TXString Universal name of the parameter.
paramIndexIFC size_t Use that overload and that parameter ONLY if you are familiar with the structure of IFC records! This is the index of the parameter in the IFC structure.
outParamIndex size_t The result - index of the parameter.
recType ERecordIFCType The record type. Possible values are ERecordIFCType::None, ERecordIFCType::IFC, ERecordIFCType::PSet, ERecordIFCType::IFCTag

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.