VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetParamIndex: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(9 intermediate revisions by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
IFC records have different structure from other Vectorworks records. Now think for IFC record as a list of pairs (property, value). The first property has index 0. Use that function to return the index. The functions has two overloads:
</desc>
</desc>


Line 16: Line 16:
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_GetParamIndex(MCObjectHandle hFormat, const TXString& paramName, size_t& outParamIndex, ERecordIFCType recType = ERecordIFCType::None);
VCOMError IFC_GetParamIndex(MCObjectHandle hFormat, const TXString& paramName, size_t& outParamIndex, ERecordIFCType recType = ERecordIFCType::None);
</funcDef>
<funcDef lang="cpp">
VCOMError IFC_GetParamIndex(MCObjectHandle hFormat, size_t paramIndexIFC, size_t& outParamIndex, ERecordIFCType recType = ERecordIFCType::None);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 28:
hFormat
hFormat
MCObjectHandle
MCObjectHandle
no info.
Handle to the record format.
</line>
</line>
<line>
<line>
paramName
paramName
TXString
TXString
no info.
Universal name of the parameter.
</line>
<line>
paramIndexIFC
size_t
Use that overload and that parameter <b>ONLY</b> if you are familiar with the structure of IFC records! This is the index of the parameter in the IFC structure.
</line>
</line>
<line>
<line>
outParamIndex
outParamIndex
size_t
size_t
no info.
The result - index of the parameter.
</line>
</line>
<line>
<line>
recType
recType
ERecordIFCType
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|ERecordIFCType]]
</line>
The record type. Possible values are ERecordIFCType::None, ERecordIFCType::IFC, ERecordIFCType::PSet, ERecordIFCType::IFCTag
<line>
no info.
</line>
</line>
</lineList>
</lineList>
Line 56: Line 62:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 79: Line 81:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_GetParamIndex2]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_GetParamIndex1]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_GetParamIndex1]]

Latest revision as of 15:25, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

IFC records have different structure from other Vectorworks records. Now think for IFC record as a list of pairs (property, value). The first property has index 0. Use that function to return the index. The functions has two overloads:

VCOMError IFC_GetParamIndex(
MCObjectHandle hFormat,
const TXString& paramName,
size_t& outParamIndex,
ERecordIFCType recType = ERecordIFCType::None);
VCOMError IFC_GetParamIndex(
MCObjectHandle hFormat,
size_t paramIndexIFC,
size_t& outParamIndex,
ERecordIFCType recType = ERecordIFCType::None);

Parameters

hFormat MCObjectHandle Handle to the record format.
paramName TXString Universal name of the parameter.
paramIndexIFC size_t Use that overload and that parameter ONLY if you are familiar with the structure of IFC records! This is the index of the parameter in the IFC structure.
outParamIndex size_t The result - index of the parameter.
recType ERecordIFCType The record type. Possible values are ERecordIFCType::None, ERecordIFCType::IFC, ERecordIFCType::PSet, ERecordIFCType::IFCTag

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.