VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetNumPsets2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 8: Line 8:


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
 
Returns the number of property sets (PSets), associated to the object. The number includes attached PSets and the PSets from IFC Data mapping.
...put some description here...
</desc>
</desc>


Line 25: Line 24:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to the object.
</line>
</line>
<line>
<line>
bAllPsets
bAllPsets
bool
bool
no info.
TRUE for all PSets, including attached to the type instance. FALSE to skip attached to the type instance.
</line>
</line>
<line>
<line>
outNumPsets
outNumPsets
short
short
no info.
Out parameter, the number of PSets.
</line>
</line>
</lineList>
</lineList>
Line 49: Line 48:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 72: Line 67:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetNumPsets|IFC_GetNumPsets]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availare from: Vectorworks 2018
</version>
</version>



Latest revision as of 07:49, 20 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport Returns the number of property sets (PSets), associated to the object. The number includes attached PSets and the PSets from IFC Data mapping.

VCOMError IFC_GetNumPsets2(
MCObjectHandle hObject,
bool bAllPsets,
short& outNumPsets);

Parameters

hObject MCObjectHandle Handle to the object.
bAllPsets bool TRUE for all PSets, including attached to the type instance. FALSE to skip attached to the type instance.
outNumPsets short Out parameter, the number of PSets.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Availare from: Vectorworks 2018

See Also

IFC_GetNumPsets

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetNumPsets|IFC_GetNumPsets]]