VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetNumPsets: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(8 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 8: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the number of attached property sets (PSets).
</desc>
</desc>


Line 16: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE IFC_GetNumPsets(MCObjectHandle hObject, short& numPsets) = 0;
VCOMError IFC_GetNumPsets(MCObjectHandle hObject, short& numPsets);
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to the object.
</line>
</line>
<line>
<line>
numPsets
numPsets
short&
short
no info.
Out parameter, the number of PSets.
</line>
</line>
</lineList>
</lineList>
Line 43: Line 42:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoError
Bad VCOM instance used to call the fuction.
The function succeeded. No Error!
</line>
</line>
<line>
<line>
Line 55: Line 54:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
</remark>
</remark>


Line 63: Line 63:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetNumPsets2|IFC_GetNumPsets2]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availare from: Vectorworks 2009
</version>
</version>



Latest revision as of 07:55, 6 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the number of attached property sets (PSets).

VCOMError IFC_GetNumPsets(
MCObjectHandle hObject,
short& numPsets);

Parameters

hObject MCObjectHandle Handle to the object.
numPsets short Out parameter, the number of PSets.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Availare from: Vectorworks 2009

See Also

IFC_GetNumPsets2

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetNumPsets2|IFC_GetNumPsets2]]