VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity2

From Vectorworks Developer
Revision as of 10:46, 20 July 2018 by KGoranov (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the IFC entity name attached/mapped to an object.

VCOMError IFC_GetIFCEntity2(
MCObjectHandle hObject,
short& iIfcRecordType,
TXString& strIfcNameByRecord,
TXString& strIfcNameByMap);

Parameters

hObject MCObjectHandle Handle to object.
iIfcRecordType short Returns the type of record. Possible values: 0(no record attached), 1(tag data record attached), 2(IFC data record attached)
strIfcNameByRecord TXString Returns the IFC name according to the record attached. Empty if no record attached to the object.
strIfcNameByMap TXString Returns the IFC name according to the mapping. Empty if no mapping assigned to the object

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018