VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the IFC entity name attached/mapped to an object.
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
iIfcRecordType
iIfcRecordType
short
short
no info.
Returns the type of record. Possible values: 0(no record attached), 1(tag data record attached), 2(IFC data record attached)
</line>
</line>
<line>
<line>
strIfcNameByRecord
strIfcNameByRecord
TXString
TXString
no info.
Returns the IFC name according to the record attached. Empty if no record attached to the object.
</line>
</line>
<line>
<line>
strIfcNameByMap
strIfcNameByMap
TXString
TXString
no info.
Returns the IFC name according to the mapping. Empty if no mapping assigned to the object
</line>
</line>
</lineList>
</lineList>
Line 54: Line 54:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 81: Line 77:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2018
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_GetIFCEntity2]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_GetIFCEntity2]]

Latest revision as of 10:46, 20 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the IFC entity name attached/mapped to an object.

VCOMError IFC_GetIFCEntity2(
MCObjectHandle hObject,
short& iIfcRecordType,
TXString& strIfcNameByRecord,
TXString& strIfcNameByMap);

Parameters

hObject MCObjectHandle Handle to object.
iIfcRecordType short Returns the type of record. Possible values: 0(no record attached), 1(tag data record attached), 2(IFC data record attached)
strIfcNameByRecord TXString Returns the IFC name according to the record attached. Empty if no record attached to the object.
strIfcNameByMap TXString Returns the IFC name according to the mapping. Empty if no mapping assigned to the object

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018