VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


returns the IFC name of an object
Returns the IFC entity name attached to an object.
</desc>
</desc>


Line 30: Line 30:
strIfcObjName
strIfcObjName
TXString
TXString
Returns the IFC name.
Returns the IFC entity name.
</line>
</line>
</lineList>
</lineList>
Line 58: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function will return the IFC name only if there is IFC data attached to the object. Othwerwise use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]].
Note that this function will return the IFC entity name only if there is IFC data attached to the object. For default IFC entity name of an object that doesn't have data attached to it use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]].


Use this function via global pointer gIFC.
Use this function via global pointer gIFC.

Revision as of 12:12, 23 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the IFC entity name attached to an object.

VCOMError IFC_GetIFCEntity(
MCObjectHandle hObject,
TXString& strIfcObjName;)

Parameters

hObject MCObjectHandle Handle to object.
strIfcObjName TXString Returns the IFC entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Note that this function will return the IFC entity name only if there is IFC data attached to the object. For default IFC entity name of an object that doesn't have data attached to it use IFC GetIFCEntity2.

Use this function via global pointer gIFC.

Version

Vectorworks 12.

See Also

IFC GetIFCEntity2

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]]