VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(No difference)

Revision as of 07:50, 5 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the IFC entity name attached to an object.

VCOMError IFC_GetIFCEntity(
MCObjectHandle hObject,
TXString& strIfcObjName;)

Parameters

hObject MCObjectHandle Handle to object.
strIfcObjName TXString Returns the IFC entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Note that this function will return the IFC entity name only if there is IFC data attached to the object.

Returning the default IFC entity name of an object that doesn't have IFC data attached to it can be executed using the IFC GetIFCEntity2 function.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

IFC GetIFCEntity2

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]]