VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
(13 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 8: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the IFC entity name attached to an object.
</desc>
</desc>


Line 16: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE IFC_GetIFCEntity(MCObjectHandle hObject, TXString& strIfcObjName) = 0;
VCOMError IFC_GetIFCEntity(MCObjectHandle hObject, TXString& strIfcObjName;
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
strIfcObjName
strIfcObjName
[[SDK:TXString]]&
TXString
no info.
Returns the IFC entity name.
</line>
</line>
</lineList>
</lineList>
Line 49: Line 48:
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</line>
</lineList>
</lineList>
Line 55: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function will return the IFC entity name only if there is IFC data attached to the object.
Returning the default IFC entity name of an object that doesn't have IFC data attached to it can be executed using the [[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]] function.
Use this function via global pointer gIFC.
</remark>
</remark>


Line 63: Line 71:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>



Latest revision as of 15:04, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the IFC entity name attached to an object.

VCOMError IFC_GetIFCEntity(
MCObjectHandle hObject,
TXString& strIfcObjName;)

Parameters

hObject MCObjectHandle Handle to object.
strIfcObjName TXString Returns the IFC entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Note that this function will return the IFC entity name only if there is IFC data attached to the object.

Returning the default IFC entity name of an object that doesn't have IFC data attached to it can be executed using the IFC GetIFCEntity2 function.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

IFC GetIFCEntity2

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]]