VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(6 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


returns the IFC name of an object
Returns the IFC entity name attached to an object.
</desc>
</desc>


Line 30: Line 30:
strIfcObjName
strIfcObjName
TXString
TXString
Returns the IFC name.
Returns the IFC entity name.
</line>
</line>
</lineList>
</lineList>
Line 58: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function will return the IFC name only if there is IFC data attached to the object. Othwerwise use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]].
Note that this function will return the IFC entity name only if there is IFC data attached to the object.  
Returning the default IFC entity name of an object that doesn't have IFC data attached to it can be executed using the [[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]] function.
 


Use this function via global pointer gIFC.
Use this function via global pointer gIFC.
Line 69: Line 71:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Vectorworks 12.
Available from: Vectorworks 12.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_GetIFCEntity]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_GetIFCEntity]]

Latest revision as of 15:04, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the IFC entity name attached to an object.

VCOMError IFC_GetIFCEntity(
MCObjectHandle hObject,
TXString& strIfcObjName;)

Parameters

hObject MCObjectHandle Handle to object.
strIfcObjName TXString Returns the IFC entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Note that this function will return the IFC entity name only if there is IFC data attached to the object.

Returning the default IFC entity name of an object that doesn't have IFC data attached to it can be executed using the IFC GetIFCEntity2 function.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

IFC GetIFCEntity2

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]]