VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 30: Line 30:
strIfcObjName
strIfcObjName
TXString
TXString
Returns IFC name.
Returns the IFC name.
</line>
</line>
</lineList>
</lineList>
Line 58: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function will return IFC name only if there is IFC data attached to the object. Othwerwise use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]].
Note that this function will return the IFC name only if there is IFC data attached to the object. Othwerwise use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]].


Use this function via global pointer gIFC.
Use this function via global pointer gIFC.

Revision as of 12:10, 23 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

returns the IFC name of an object

VCOMError IFC_GetIFCEntity(
MCObjectHandle hObject,
TXString& strIfcObjName;)

Parameters

hObject MCObjectHandle Handle to object.
strIfcObjName TXString Returns the IFC name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Note that this function will return the IFC name only if there is IFC data attached to the object. Othwerwise use IFC GetIFCEntity2.

Use this function via global pointer gIFC.

Version

Vectorworks 12.

See Also

IFC GetIFCEntity2

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]]