VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
returns the IFC name of an object
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
strIfcObjName
strIfcObjName
TXString
TXString
no info.
Returns IFC name.
</line>
</line>
</lineList>
</lineList>
Line 48: Line 48:
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</line>
</lineList>
</lineList>
Line 54: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function will return IFC name only if there is IFC data attached to the object. Othwerwise use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]].
Use this function via global pointer gIFC.
</remark>
</remark>


Line 62: Line 69:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Vectorworks 12.
</version>
</version>



Revision as of 12:09, 23 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

returns the IFC name of an object

VCOMError IFC_GetIFCEntity(
MCObjectHandle hObject,
TXString& strIfcObjName;)

Parameters

hObject MCObjectHandle Handle to object.
strIfcObjName TXString Returns IFC name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Note that this function will return IFC name only if there is IFC data attached to the object. Othwerwise use IFC GetIFCEntity2.

Use this function via global pointer gIFC.

Version

Vectorworks 12.

See Also

IFC GetIFCEntity2

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetIFCEntity2|IFC GetIFCEntity2]]