VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetFullEntitiesList: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Returns the full list of IFC entities.
Returns the full list of IFC entities.

Latest revision as of 15:28, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the full list of IFC entities.

VCOMError IFC_GetFullEntitiesList(
EIFCSupportSchema scheme,
TXStringArray& outArrEntities,
bool buildingElemensOnly = false);

Parameters

scheme EIFCSupportSchema Choose the IFC schema.
outArrEntities TXStringArray Out parameter for the result.
buildingElemensOnly bool Default value is false. If it is true then only the building elements will be pushed in the array.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.