VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetFieldsCount: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


If the object do not uses Data Mapping, the function returns kVCOMError_Failed. Otherwise the function returns the number of fields which are mapped.
If the object do not uses Data Mapping, the function returns kVCOMError_Failed. Otherwise the function returns the number of fields which are mapped.

Latest revision as of 15:20, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

If the object do not uses Data Mapping, the function returns kVCOMError_Failed. Otherwise the function returns the number of fields which are mapped.

VCOMError IFC_GetFieldsCount(
const TXString& strObjectName,
const TXString& strEntryName,
short& outCount);

Parameters

strObjectName TXString The name of the object.
strEntryName TXString The name of the entity/pset.
outCount short The result - count of mapped fields.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.