VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetFieldType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Returns the type of the field.
Returns the type of the field.

Latest revision as of 14:57, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the type of the field.

VCOMError IFC_GetFieldType(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
short& outType,
const TXString& strPSetName = "");

Parameters

strObjectName TXString The name of the object.
strEntryName TXString The Entry name.
strFieldName TXString The field name.
outType short The return value casted short. Possible values are represented by EIfcType.
strPSetName TXString The PSet name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019