VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetFieldType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(One intermediate revision by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the type of the field.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_GetFieldType(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, short& outType);
VCOMError IFC_GetFieldType(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, short& outType, const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
The name of the object.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
The Entry name.
</line>
</line>
<line>
<line>
strFieldName
strFieldName
TXString
TXString
no info.
The field name.
</line>
</line>
<line>
<line>
outType
outType
short
short
no info.
The return value casted short. Possible values are represented by [[VCOM:VectorWorks:IFCLib:IFCEnumerations|EIfcType]].
</line>
<line>
strPSetName
TXString
The PSet name.
</line>
</line>
</lineList>
</lineList>
Line 54: Line 59:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 81: Line 82:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019
</version>
</version>



Latest revision as of 14:57, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the type of the field.

VCOMError IFC_GetFieldType(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
short& outType,
const TXString& strPSetName = "");

Parameters

strObjectName TXString The name of the object.
strEntryName TXString The Entry name.
strFieldName TXString The field name.
outType short The return value casted short. Possible values are represented by EIfcType.
strPSetName TXString The PSet name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019