VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetFieldName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Gets the Name of an IfcEntity Field or Property Set(PSet) Field Mapped to that IfcEntity.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_AddField(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, const short& type, bool bOptional, bool bEnable, bool bEmpty);
VCOMError IFC_GetFieldName(const TXString& strObjectName, const TXString& strEntryName, const size_t index, TXString& outFieldName, const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object name.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
IfcEntity Name.
</line>
</line>
<line>
<line>
strFieldName
index
TXString
size_t
no info.
The index of the Field.
</line>
</line>
<line>
<line>
type
outFieldName
short
TXString
no info.
The returned Field Name value.
</line>
</line>
<line>
<line>
bOptional
strPSetName
bool
TXString
no info.
PSet Name.
</line>
<line>
bEnable
bool
no info.
</line>
<line>
bEmpty
bool
no info.
</line>
</line>
</lineList>
</lineList>
Line 69: Line 59:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 96: Line 82:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019
</version>
</version>



Latest revision as of 07:10, 2 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Gets the Name of an IfcEntity Field or Property Set(PSet) Field Mapped to that IfcEntity.

VCOMError IFC_GetFieldName(
const TXString& strObjectName,
const TXString& strEntryName,
const size_t index,
TXString& outFieldName,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString IfcEntity Name.
index size_t The index of the Field.
outFieldName TXString The returned Field Name value.
strPSetName TXString PSet Name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019