VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetFieldMapping

From Vectorworks Developer
Revision as of 14:50, 31 August 2018 by NBeshevliev (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Gets the Mapping Source of an IfcEntity Field or Property Set(PSet) Field Mapped to that IfcEntity.

VCOMError IFC_GetFieldMapping(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
TXString& outValue,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString IfcEntity name.
strFieldName TXString Field name.
outValue TXString Returned Mapping Source text.
strPSetName TXString Property Set name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.