VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetFieldMapping: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Gets the Mapping Source of an IfcEntity Field or Property Set(PSet) Field Mapped to that IfcEntity.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_GetFieldMapping(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, TXString& outValue);
VCOMError IFC_GetFieldMapping(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, TXString& outValue, const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object name.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
IfcEntity name.
</line>
</line>
<line>
<line>
strFieldName
strFieldName
TXString
TXString
no info.
Field name.
</line>
</line>
<line>
<line>
outValue
outValue
TXString
TXString
no info.
Returned Mapping Source text.
</line>
<line>
strPSetName
TXString
Property Set name.
</line>
</line>
</lineList>
</lineList>
Line 54: Line 59:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 81: Line 82:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019.
</version>
</version>



Latest revision as of 14:50, 31 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Gets the Mapping Source of an IfcEntity Field or Property Set(PSet) Field Mapped to that IfcEntity.

VCOMError IFC_GetFieldMapping(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
TXString& outValue,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString IfcEntity name.
strFieldName TXString Field name.
outValue TXString Returned Mapping Source text.
strPSetName TXString Property Set name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.