VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntryName

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the name of the mapped IFC entity name according to the data mapping.

VCOMError IFC_GetEntryName(
const size_t index,
const TXString& strObjectName,
TXString& outEntryName);

Parameters

index size_t Index of the mapped etiity.
strObjectName TXString The name of the parametric object.
outEntryName TXString The result.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.