VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntryName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(2 intermediate revisions by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the name of the mapped IFC entity name according to the data mapping.
</desc>
</desc>


Line 25: Line 25:
index
index
size_t
size_t
no info.
Index of the mapped etiity.
</line>
</line>
<line>
<line>
strObjectName
strObjectName
TXString
TXString
no info.
The name of the parametric object.
</line>
</line>
<line>
<line>
outEntryName
outEntryName
TXString
TXString
no info.
The result.
</line>
</line>
</lineList>
</lineList>
Line 49: Line 49:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 76: Line 72:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_GetEntryName]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_GetEntryName]]

Latest revision as of 15:20, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the name of the mapped IFC entity name according to the data mapping.

VCOMError IFC_GetEntryName(
const size_t index,
const TXString& strObjectName,
TXString& outEntryName);

Parameters

index size_t Index of the mapped etiity.
strObjectName TXString The name of the parametric object.
outEntryName TXString The result.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.