VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntriesCount: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Returns IfcEntity groups count for Object.
</desc>
</desc>


Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object name.
</line>
</line>
<line>
<line>
outCount
outCount
short
short
no info.
Returned IfcEntity groups count.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 44:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 71: Line 67:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017.
</version>
</version>



Revision as of 07:01, 5 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns IfcEntity groups count for Object.

VCOMError IFC_GetEntriesCount(
const TXString& strObjectName,
short& outCount);

Parameters

strObjectName TXString Object name.
outCount short Returned IfcEntity groups count.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.