VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntityProp2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 45: Line 45:
outMap
outMap
short
short
no info.
For more info: [[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]]
</line>
</line>
</lineList>
</lineList>

Revision as of 13:15, 3 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

...put some description here...

VCOMError IFC_GetEntityProp2(
MCObjectHandle hObject,
const TXString& strIfcPropName,
TXString& outStrIfcPropValue,
short& iType,
short& outMap);

Parameters

hObject MCObjectHandle no info.
strIfcPropName TXString no info.
outStrIfcPropValue TXString no info.
iType short no info.
outMap short For more info: IFC Enumerations

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: