VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntityProp2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 40: Line 40:
iType
iType
short
short
Retruns the property type. Possible values:  UNKNOWN(0), IDENTIFIER(1), DOUBLE(2); BOOLEAN(3); INTEGER(4); NUMBER(5); LOGICAL(6); STRING(7); ENUMERATION(8); SELECT(9)
Retruns the property type. Possible values:  UNKNOWN(0), IDENTIFIER(1), DOUBLE(2); BOOLEAN(3); INTEGER(4); NUMBER(5); LOGICAL(6); STRING(7); ENUMERATION(8); SELECT(9).
</line>
</line>
<line>
<line>
outMap
outMap
short
short
Returns the source for the value. Possible values: eNotSet(-1); eFromInstance(0); eFromMapping(1). For more info: [[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]]
Returns the source for the value. Possible values: eNotSet(-1); eFromInstance(0); eFromMapping(1). For more info: [[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]].
</line>
</line>
</lineList>
</lineList>

Latest revision as of 15:22, 23 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the property value of an entity property.

VCOMError IFC_GetEntityProp2(
MCObjectHandle hObject,
const TXString& strIfcPropName,
TXString& outStrIfcPropValue,
short& iType,
short& outMap);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPropName TXString Property name.
outStrIfcPropValue TXString Returns the property value.
iType short Retruns the property type. Possible values: UNKNOWN(0), IDENTIFIER(1), DOUBLE(2); BOOLEAN(3); INTEGER(4); NUMBER(5); LOGICAL(6); STRING(7); ENUMERATION(8); SELECT(9).
outMap short Returns the source for the value. Possible values: eNotSet(-1); eFromInstance(0); eFromMapping(1). For more info: IFC Enumerations.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Note that this function returns only property values from entities. For values from Property Sets please use IFC_GetPsetProp2.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.

See Also

IFC_GetPsetProp2.

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetProp2|IFC_GetPsetProp2]].