VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntityProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE IFC_GetEntityProp(MCObjectHandle hObject, const TXString& strIfcPropName, TXString& strIfcPropValue, short& iType) = 0;
VCOMError IFC_GetEntityProp(MCObjectHandle hObject, const TXString& strIfcPropName, TXString& strIfcPropValue, short& iType);
</funcDef>
</funcDef>
</def>
</def>
Line 29: Line 29:
<line>
<line>
strIfcPropName
strIfcPropName
const [[SDK:TXString]]&
TXString
no info.
no info.
</line>
</line>
<line>
<line>
strIfcPropValue
strIfcPropValue
[[SDK:TXString]]&
TXString
no info.
no info.
</line>
</line>

Revision as of 11:54, 23 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

...put some description here...

VCOMError IFC_GetEntityProp(
MCObjectHandle hObject,
const TXString& strIfcPropName,
TXString& strIfcPropValue,
short& iType);

Parameters

hObject MCObjectHandle no info.
strIfcPropName TXString no info.
strIfcPropValue TXString no info.
iType short& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.