VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntityProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(3 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Returns the property value of an entity property.  
Returns the property value of an entity property.  
Line 68: Line 68:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function returns only property values from entities. For values from Property Sets please use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetPsetProp|IFC_GetPsetProp]].
Note that this function returns only property values from entities. For values from Property Sets please use [[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetProp|IFC_GetPsetProp]].
Note that this function will return a value only if there is an attached IFC record to the objects. If you want to have the IFC Data Mapping value for the property returned, please use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC_GetEntityProp2|IFC_GetEntityProp2]].
Note that this function will return a value only if there is an attached IFC record to the objects. If you want to have the IFC Data Mapping value for the property returned, please use [[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp2|IFC_GetEntityProp2]].




Line 81: Line 81:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCProperty|IIFCSupport::GetIFCProperty]]
</seeAlso>
</seeAlso>


Line 90: Line 91:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_GetEntityProp]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_GetEntityProp]]

Latest revision as of 15:03, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the property value of an entity property.

VCOMError IFC_GetEntityProp(
MCObjectHandle hObject,
const TXString& strIfcPropName,
TXString& strIfcPropValue,
short& iType);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPropName TXString Property name.
strIfcPropValue TXString Returns the property value.
iType short Retruns the property type. Possible values: UNKNOWN(0), IDENTIFIER(1), DOUBLE(2); BOOLEAN(3); INTEGER(4); NUMBER(5); LOGICAL(6); STRING(7); ENUMERATION(8); SELECT(9)

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Note that this function returns only property values from entities. For values from Property Sets please use IFC_GetPsetProp.

Note that this function will return a value only if there is an attached IFC record to the objects. If you want to have the IFC Data Mapping value for the property returned, please use IFC_GetEntityProp2.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2008.

See Also

IIFCSupport::GetIFCProperty

[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCProperty|IIFCSupport::GetIFCProperty]]