VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntityProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Returns the property value of a property.  
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
strIfcPropName
strIfcPropName
TXString
TXString
no info.
Property name.
</line>
</line>
<line>
<line>
strIfcPropValue
strIfcPropValue
TXString
TXString
no info.
Returns the property value.
</line>
</line>
<line>
<line>
iType
iType
short
short
no info.
Retruns the property type. Possible values:  UNKNOWN(0), IDENTIFIER(1), DOUBLE(2); BOOLEAN(3); INTEGER(4); NUMBER(5); LOGICAL(6); STRING(7); ENUMERATION(8); SELECT(9)
</line>
</line>
</lineList>
</lineList>
Line 64: Line 64:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function returns only property values from entities. For values from Property Sets please use IFC_GetPsetProp.
Note that this function will return a value only if there is an attached IFC record to the objects. If you want to have the IFC Data Mapping value for the property returned, please use IFC_GetEntityProp2.
Use this function via global pointer gIFC.
</remark>
</remark>


Line 76: Line 80:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>



Revision as of 14:51, 29 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the property value of a property.

VCOMError IFC_GetEntityProp(
MCObjectHandle hObject,
const TXString& strIfcPropName,
TXString& strIfcPropValue,
short& iType);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPropName TXString Property name.
strIfcPropValue TXString Returns the property value.
iType short Retruns the property type. Possible values: UNKNOWN(0), IDENTIFIER(1), DOUBLE(2); BOOLEAN(3); INTEGER(4); NUMBER(5); LOGICAL(6); STRING(7); ENUMERATION(8); SELECT(9)

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

Note that this function returns only property values from entities. For values from Property Sets please use IFC_GetPsetProp.

Note that this function will return a value only if there is an attached IFC record to the objects. If you want to have the IFC Data Mapping value for the property returned, please use IFC_GetEntityProp2.

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.