VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntityColor: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Gets the color for an IFC entity.
Gets the color for an IFC entity if RGB format and flag for transparency.
</desc>
</desc>


Line 30: Line 30:
red
red
short
short
Out parameter. Red value.
Out parameter. Red value. It varies from 0 to 255.
</line>
</line>
<line>
<line>
green
green
short
short
Out parameter. Green value.
Out parameter. Green value. It varies from 0 to 255.
</line>
</line>
<line>
<line>
blue
blue
short
short
Out parameter. Blue value.
Out parameter. Blue value. It varies from 0 to 255.
</line>
</line>
<line>
<line>
transparent
transparent
short
short
Out parameter. Possible values: 1 - tranparent, 0 - opaque.
Out parameter. Possible values: 1 - transparent, 0 - opaque.
</line>
</line>
</lineList>
</lineList>
Line 57: Line 57:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoError
Bad VCOM instance used to call the fuction.
The function succeeded. No Error!
</line>
</line>
<line>
kVCOMError_Failed
Routine failed.
</line>
</lineList>
</return>
</return>



Latest revision as of 11:25, 13 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Gets the color for an IFC entity if RGB format and flag for transparency.

VCOMError IFC_GetEntityColor(
const TXString& strIfcName,
short& red,
short& green,
short& blue,
short& transparent);

Parameters

strIfcName TXString IFC Entity name.
red short Out parameter. Red value. It varies from 0 to 255.
green short Out parameter. Green value. It varies from 0 to 255.
blue short Out parameter. Blue value. It varies from 0 to 255.
transparent short Out parameter. Possible values: 1 - transparent, 0 - opaque.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning: <lineList ident=1>

kVCOMError_NoError The function succeeded. No Error!

Version

Available from: Vectorworks 12.