VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntityColor: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 16: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE IFC_GetEntityColor(const TXString& strIfcName, short& red, short& green, short& blue, short& transparent) = 0;
VCOMError IFC_GetEntityColor(const TXString& strIfcName, short& red, short& green, short& blue, short& transparent);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 24:
<line>
<line>
strIfcName
strIfcName
const [[SDK:TXString]]&
TXString
no info.
no info.
</line>
</line>
<line>
<line>
red
red
short&
short
no info.
no info.
</line>
</line>
<line>
<line>
green
green
short&
short
no info.
no info.
</line>
</line>
<line>
<line>
blue
blue
short&
short
no info.
no info.
</line>
</line>
<line>
<line>
transparent
transparent
short&
short
no info.
no info.
</line>
</line>

Revision as of 11:57, 23 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

...put some description here...

VCOMError IFC_GetEntityColor(
const TXString& strIfcName,
short& red,
short& green,
short& blue,
short& transparent);

Parameters

strIfcName TXString no info.
red short no info.
green short no info.
blue short no info.
transparent short no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.