VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetEntityColor: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(10 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 8: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Gets the color for an IFC entity if RGB format and flag for transparency.
</desc>
</desc>


Line 16: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE IFC_GetEntityColor(const TXString& strIfcName, short& red, short& green, short& blue, short& transparent) = 0;
VCOMError IFC_GetEntityColor(const TXString& strIfcName, short& red, short& green, short& blue, short& transparent);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 24:
<line>
<line>
strIfcName
strIfcName
const [[SDK:TXString]]&
TXString
no info.
IFC Entity name.
</line>
</line>
<line>
<line>
red
red
short&
short
no info.
Out parameter. Red value. It varies from 0 to 255.
</line>
</line>
<line>
<line>
green
green
short&
short
no info.
Out parameter. Green value. It varies from 0 to 255.
</line>
</line>
<line>
<line>
blue
blue
short&
short
no info.
Out parameter. Blue value. It varies from 0 to 255.
</line>
</line>
<line>
<line>
transparent
transparent
short&
short
no info.
Out parameter. Possible values: 1 - transparent, 0 - opaque.
</line>
</line>
</lineList>
</lineList>
Line 58: Line 57:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoError
Bad VCOM instance used to call the fuction.
The function succeeded. No Error!
</line>
<line>
kVCOMError_Failed
Routine failed.
</line>
</line>
</lineList>
</return>
</return>


Line 82: Line 76:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>



Latest revision as of 11:25, 13 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Gets the color for an IFC entity if RGB format and flag for transparency.

VCOMError IFC_GetEntityColor(
const TXString& strIfcName,
short& red,
short& green,
short& blue,
short& transparent);

Parameters

strIfcName TXString IFC Entity name.
red short Out parameter. Red value. It varies from 0 to 255.
green short Out parameter. Green value. It varies from 0 to 255.
blue short Out parameter. Blue value. It varies from 0 to 255.
transparent short Out parameter. Possible values: 1 - transparent, 0 - opaque.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning: <lineList ident=1>

kVCOMError_NoError The function succeeded. No Error!

Version

Available from: Vectorworks 12.