VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetCOBieSource: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(2 intermediate revisions by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Returns the data source of the selected worksheet and column of an object.
Returns the data source of the selected worksheet and column of an object.
Line 102: Line 102:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetCOBieProperty|IFC_GetCOBieProperty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetCOBieProperty|IFC_GetCOBieProperty]]
</seeAlso>
</seeAlso>


Line 112: Line 112:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_GetCOBieSource]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_GetCOBieSource]]

Latest revision as of 15:19, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the data source of the selected worksheet and column of an object.

virtual VCOMError VCOM_CALLTYPE IFC_GetCOBieSource(
MCObjectHandle hObject,
const TXString& worksheetName,
const TXString& columnName,
const TXString& country,
const TXString& version,
TXString& outResult);
virtual VCOMError VCOM_CALLTYPE IFC_GetCOBieSource(
MCObjectHandle hObject,
const TXString& argStrings,
TXString& outResult);

Parameters

hObject MCObjectHandle Handle to object.
worksheetName TXString Name of the worksheet.
columnName TXString Name of the column in the worksheet.
country TXString COBie version based on country of origin. Optional parameter. Default value: "US".
version TXString COBie version based on the standard version. Optional parameter. Default value: "2.4".
argStrings TXString The worksheetName, columnName, version and country strings all filled into one string divided by ".". Version and country are also optional for this parameter.
outResult TXString Returned string.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

This function is usually used with COBie worksheet function GetCOBieSource(criteria). The criteria is a string with two elements separated by a period. The first element is the name of the COBie worksheet and the second element is the name of the column in that worksheet

Example: =GETCOBIESOURCE ('space.floorname') returns the FloorName data source for objects whose COBie property is Space.

Please note that the version and country strings are not mandatory and can be left empty. They ensure that any new version in the COBie standard can easily be implemented in future Vectorworks releases. As of Vectorworks 2019, they do not affect the outResult.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.

See Also

IFC_GetCOBieProperty

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetCOBieProperty|IFC_GetCOBieProperty]]