VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetCOBieSource: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Returns the data source of the selected worksheet and column of an object.
</desc>
</desc>


Line 18: Line 18:
</funcDef>
</funcDef>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMError VCOM_CALLTYPE IFC_GetCOBieSource(MCObjectHandle hObject, const TXString& argStrings, TXString& outResuIsPsetCustomlt);outResult);
virtual VCOMError VCOM_CALLTYPE IFC_GetCOBieSource(MCObjectHandle hObject, const TXString& argStrings, TXString& outResult);
</funcDef>
</funcDef>
</def>
</def>
Line 28: Line 28:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
worksheetName
worksheetName
TXString
TXString
no info.
Name of the worksheet.
</line>
</line>
<line>
<line>
columnName
columnName
TXString
TXString
no info.
Name of the column in the worksheet.
</line>
</line>
<line>
<line>
country
country
TXString
TXString
no info.
COBie version based on country of origin. Optional parameter. Default value: "US".
</line>
</line>
<line>
<line>
version
version
TXString
TXString
no info.
COBie version based on the standard version. Optional parameter. Default value: "2.4".
</line>
<line>
outResult
TXString
no info.
</line>
</line>
<line>
<line>
argStrings
argStrings
TXString
TXString
no info.
The worksheetName, columnName, version and country strings all filled into one string divided by ".". Version and country are also optional for this parameter.
</line>
</line>
<line>
<line>
outResuIsPsetCustomlt
outResult
TXString
TXString
no info.
Returned string.
</line>
</line>
</lineList>
</lineList>
Line 91: Line 86:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
This function is usually used with COBie worksheet function GetCOBieSource(criteria). The criteria is a string with two elements separated by a period. The first element is the name of the COBie worksheet and the second element is the name of the column in that worksheet
Example: =GETCOBIESOURCE ('space.floorname') returns the FloorName data source for objects whose COBie property is Space.
Please note that the version and country strings are not mandatory and can be left empty. They ensure that any new version in the COBie standard can easily be implemented in future Vectorworks releases. As of Vectorworks 2019, they do not affect the outResult.
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
</remark>  
</remark>  
Line 100: Line 102:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetCOBieProperty|IFC_GetCOBieProperty]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2018.
</version>
</version>



Revision as of 11:09, 2 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the data source of the selected worksheet and column of an object.

virtual VCOMError VCOM_CALLTYPE IFC_GetCOBieSource(
MCObjectHandle hObject,
const TXString& worksheetName,
const TXString& columnName,
const TXString& country,
const TXString& version,
TXString& outResult);
virtual VCOMError VCOM_CALLTYPE IFC_GetCOBieSource(
MCObjectHandle hObject,
const TXString& argStrings,
TXString& outResult);

Parameters

hObject MCObjectHandle Handle to object.
worksheetName TXString Name of the worksheet.
columnName TXString Name of the column in the worksheet.
country TXString COBie version based on country of origin. Optional parameter. Default value: "US".
version TXString COBie version based on the standard version. Optional parameter. Default value: "2.4".
argStrings TXString The worksheetName, columnName, version and country strings all filled into one string divided by ".". Version and country are also optional for this parameter.
outResult TXString Returned string.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

This function is usually used with COBie worksheet function GetCOBieSource(criteria). The criteria is a string with two elements separated by a period. The first element is the name of the COBie worksheet and the second element is the name of the column in that worksheet

Example: =GETCOBIESOURCE ('space.floorname') returns the FloorName data source for objects whose COBie property is Space.

Please note that the version and country strings are not mandatory and can be left empty. They ensure that any new version in the COBie standard can easily be implemented in future Vectorworks releases. As of Vectorworks 2019, they do not affect the outResult.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.

See Also

IFC_GetCOBieProperty

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetCOBieProperty|IFC_GetCOBieProperty]]