VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetCOBieProperty

From Vectorworks Developer
Revision as of 11:06, 2 April 2018 by KGoranov (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the value of a COBie property for an object.

VCOMError IFC_GetCOBieProperty(
MCObjectHandle hObject,
const TXString& worksheetName,
const TXString& columnName,
const TXString& country,
const TXString& version,
TXString& outResult);
VCOMError IFC_GetCOBieProperty(
MCObjectHandle hObject,
const TXString& argStrings,
TXString& outResult);

Parameters

hObject MCObjectHandle Handle to object.
worksheetName TXString Name of the worksheet.
columnName TXString Name of the column in the worksheet.
country TXString COBie version based on country of origin. Optional parameter. Default value: "US".
version TXString COBie version based on the standard version. Optional parameter. Default value: "2.4".
argStrings TXString The worksheetName, columnName, version and country strings all filled into one string divided by ".". Version and country are also optional for this parameter.
outResult TXString Returned string.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

This function is usually used with COBie worksheet function GetCOBieProperty(criteria). The criteria is a string with two elements separated by a period. An example of the worksheet function is at it follows: =GETCOBIEPROPERTY ('space.floorname') The first element the name of the COBie worksheet and the second element is the name of the column in that worksheet. This example will return the FloorName value for objects whose COBie property is Space.

Please note that the version and country strings are not mandatory and can be left empty. They ensure that any new version in the COBie standard can easily be implemented in future Vectorworks releases. As of Vectorworks 2019, they do not affect the outResult.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.

See Also

IFC_GetCOBieSource

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetCOBieSource|IFC_GetCOBieSource]]