VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetCOBieProperty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Returns the COBie column cell value for the corresponding object.
</desc>
</desc>


Line 28: Line 28:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
worksheetName
worksheetName
TXString
TXString
no info.
Name of the worksheet
</line>
</line>
<line>
<line>
columnName
columnName
TXString
TXString
no info.
Name of the column in the worksheet
</line>
</line>
<line>
<line>
country
country
TXString
TXString
no info.
COBie version based on country of origin. Default value: "US"
</line>
</line>
<line>
<line>
version
version
TXString
TXString
no info.
COBie version based on the standard version. Default value: 2.4
</line>
</line>
<line>
<line>
Line 58: Line 58:
outResult
outResult
TXString
TXString
no info.
Value returned
</line>
</line>
</lineList>
</lineList>
Line 95: Line 95:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetCOBieSource|IFC_GetCOBieSource]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2018.
</version>
</version>



Revision as of 10:44, 2 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the COBie column cell value for the corresponding object.

VCOMError IFC_GetCOBieProperty(
MCObjectHandle hObject,
const TXString& worksheetName,
const TXString& columnName,
const TXString& country,
const TXString& version,
TXString& outResult);
VCOMError IFC_GetCOBieProperty(
MCObjectHandle hObject,
const TXString& argStrings,
TXString& outResult);

Parameters

hObject MCObjectHandle Handle to object.
worksheetName TXString Name of the worksheet
columnName TXString Name of the column in the worksheet
country TXString COBie version based on country of origin. Default value: "US"
version TXString COBie version based on the standard version. Default value: 2.4
argStrings TXString no info.
outResult TXString Value returned

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.

See Also

IFC_GetCOBieSource

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC GetCOBieSource|IFC_GetCOBieSource]]