VCOM:VectorWorks:IFCLib:IIFCSupport::IFC EnableObject

From Vectorworks Developer
Revision as of 14:45, 2 April 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the IFC mapping and IFC export status of the object. If bEnable = true then the mapping is specified for the object, and the object will be exported to IFC. If bEnable = false then the mapping is specified for this object, but the object is excluded from export by the Export IFC Project command.

VCOMError IFC_EnableObject(
const TXString& strObjectName,
bool bEnable);

Parameters

strObjectName TXString Object name.
bEnable bool Include/exclude the object from export by the Export IFC Project command.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.