VCOM:VectorWorks:IFCLib:IIFCSupport::IFC EnableObject: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Sets the IFC mapping and IFC export status of the object.  
Sets the IFC mapping and IFC export status of the object.  

Latest revision as of 15:22, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the IFC mapping and IFC export status of the object. If bEnable = true then the mapping is specified for the object, and the object will be exported to IFC. If bEnable = false then the mapping is specified for this object, but the object is excluded from export by the Export IFC Project command.

VCOMError IFC_EnableObject(
const TXString& strObjectName,
bool bEnable);

Parameters

strObjectName TXString Object name.
bEnable bool Include/exclude the object from export by the Export IFC Project command.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.