VCOM:VectorWorks:IFCLib:IIFCSupport::IFC EnableObject: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Sets the IFC mapping and IFC export status of the object.  
If bEnable = true then the mapping is specified for the object, and the object will be exported to IFC.
If bEnable = false then the mapping is specified for this object, but the object is excluded from export by the Export IFC Project command.
</desc>
</desc>


Line 25: Line 27:
strObjectName
strObjectName
TXString
TXString
no info.
Object name.
</line>
</line>
<line>
<line>
bEnable
bEnable
bool
bool
no info.
Include/exclude the object from export by the Export IFC Project command.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 46:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>

Revision as of 14:45, 2 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the IFC mapping and IFC export status of the object. If bEnable = true then the mapping is specified for the object, and the object will be exported to IFC. If bEnable = false then the mapping is specified for this object, but the object is excluded from export by the Export IFC Project command.

VCOMError IFC_EnableObject(
const TXString& strObjectName,
bool bEnable);

Parameters

strObjectName TXString Object name.
bEnable bool Include/exclude the object from export by the Export IFC Project command.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.