VCOM:VectorWorks:IFCLib:IIFCSupport::IFC EnableEntry: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
 
(4 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Sets the IFC Data Mapping export status of an object's Entry. Enables/Disables the Entry so it can be exported. If the user want to Enable/Disable a Property Set, he must provide the IfcEntity name for that Property Set.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_EnableEntry(const TXString& strObjectName, const TXString& strEntryName, bool bEnable);
VCOMError IFC_EnableEntry(const TXString& strObjectName, const TXString& strEntryName, bool bEnable, const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object name.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
IfcEntity name.
</line>
</line>
<line>
<line>
bEnable
bEnable
bool
bool
no info.
Include/exclude the Entry from export by the Export IFC Project command.
</line>
<line>
strPSetName
TXString
Ifc Property Set name for the indicated IfcEntity.  
</line>
</line>
</lineList>
</lineList>
Line 49: Line 54:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 76: Line 77:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_EnableEntry]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_EnableEntry]]

Latest revision as of 15:21, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the IFC Data Mapping export status of an object's Entry. Enables/Disables the Entry so it can be exported. If the user want to Enable/Disable a Property Set, he must provide the IfcEntity name for that Property Set.

VCOMError IFC_EnableEntry(
const TXString& strObjectName,
const TXString& strEntryName,
bool bEnable,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString IfcEntity name.
bEnable bool Include/exclude the Entry from export by the Export IFC Project command.
strPSetName TXString Ifc Property Set name for the indicated IfcEntity.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.