VCOM:VectorWorks:IFCLib:IIFCSupport::IFC EnableEntry: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 54: Line 54:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>

Revision as of 13:32, 27 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the IFC Data Mapping export status of an object's Entry. Enables/Disables the Entry so it can be exported. If the user want to Enable/Disable a Property Set, he must provide the IfcEntity name for that Property Set.

VCOMError IFC_EnableEntry(
const TXString& strObjectName,
const TXString& strEntryName,
bool bEnable,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString IfcEntity name.
bEnable bool Include/exclude the Entry from export by the Export IFC Project command.
strPSetName TXString Ifc Property Set name for the indicated IfcEntity.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.