VCOM:VectorWorks:IFCLib:IIFCSupport::IFC DeleteIFCInfo

From Vectorworks Developer
Revision as of 12:10, 28 June 2018 by Sasha (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Deletes all IFC data, attached to the object.

VCOMError IFC_DeleteIFCInfo(
MCObjectHandle hObject,
bool bDoUndo);

Parameters

hObject MCObjectHandle Handle to the object.
bDoUndo bool Use undo or not.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017