VCOM:VectorWorks:IFCLib:IIFCSupport::IFC DeleteEntry

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Deletes the Ifc Entity and the Property Sets (PSets) mapped to it according to IFC Data Mapping

VCOMError IFC_DeleteEntry(
const TXString& strObjectName,
const TXString& strEntryName);

Parameters

strObjectName TXString Object name from which the user is deleting.
strEntryName TXString Ifc Entity name which is going to be deleted.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.